Posts Tagged ‘first glimpse’

Skype remove word completion / Howto Disable spellcheck autocorrect on Mac OS X, Android Phones Tablets and IPhone iOS

Tuesday, March 14th, 2017

How-to-disable-auto-correct-on-MacOS-X-android-and-iphone

I've recently upgraded my wife's Mac Book Air Mac OS X release from Mountain Lion to latest available OS X release Yosemite and after upgrade the old version of Skype used for about 3 years without any problems (except camera issues due to mac OS X bug the old post is here) stopped working (did crashed) on Skype launch so I took few minutes to upgrade Skype as well from Skype.com Skype for Mac official download page after the quick and unproblematic Skype re-install, Skype client was back to normal with a shiny new outlook and on a first glimpse all worked like a charm but …

On the next day when I took use of temporary the upgraded Mac Book Air with the fresh new OS X Yosemite and Skype's latest app to to do a quick login with my Skype credentials noticed a very annoying autocorrect (auto spelling)  Skype behavior on any new input text message.

I have to admit the idea of autocorrect feature on a system wide scale is great however quick keyboard typers like me who are used to type more than a letter per second use to type so quickly that occasinally you do errors which you're quick to fix but anyhow errors are automatically corrected in a way that you have to retype the whole word quite often which makes your typing a hellish experience. Then the same auto-correct feature becomes a terrible experience and on any device I notice this behavior I tend to remove it immediately.

I remember  the same dictionary auto-spell check / corect behavior was present on my Android run ZTE blade 3 mobile after first Mobile boot and also present on my current iPhone 5 iOS and thus the first thing I did once I start using it is to remove autocorrect (auto spelling) feature and relax the irritation of it.

Just in case if you need to disable Spellcheck auto-correct on Android Phone or Tablet do it from

Settings -> Language & input

android-phone-tablet-disable-autocorrect-spell-check

If you happen to be using also IPhone 5 as me or  Iphone 6 / 7 to disable AutoCorrect feature on SMSes / Skype / Viber and other applications do it from Phone's:

Settings -> General

disable_Turn_off_AutoCorrect_in_IPhone_iOS

Shortly I've noticed that the auto-correct feature does not only mess up your typing in Skype but also in Mail and TweetDeck and generally any open application where you can type on Yosemite.


I've took the time to investigate quickly what was causing the new feature that bugged me so much online and came to this nice little article How to turnoff autocorrect on Mac OS X 10.11 El Captain

As the article revealed to Turn off the autocorrect Mac OS X feature you I have to go:

Finder -> System Preferences

 

stop-skype-autocorrect-annoying-macosx-yosemite-system-preferences-menu-screenshot

Click on Keyboard -> Text
and turn  Autocorrect off by unchecking Correct spelling automatically

stop-skype-autocorrect-annoying-macosx-yosemite-system-preferences-keyboard-menu-screenshot

By doing this autocorrect spelling is disabled for all applications, however for some people it might be handy to leave the correct feature for Mail app or Microsoft Office (Microsoft Word / Excel) etc. and only turn off (disable) the autorrect feature per application side.

You can  do this in the separate Applications (of choise where you need auto spelling) from  Edit Menu under Spelling and Grammer and enable / disableCheck Spelling While Typing

stop-skype-autocorrect-annoying-macosx-yosemite-spelling-and-grammar-menu-screenshot


Tadam Enjoy ! 🙂

 

Windows XP: Fixing External Hard / Pen USB stick Missing Shortcuts (Problem with Shortcut) solution

Monday, December 17th, 2012

windows error problem with shortcut the item 689342.exe  refers has been changed or moved

I was asked today to fix a computer with 682 GB external Hard Drive attached. For some unexplainable reason, many of the Directories storing hundreds of gygas of precious data become showing up as "Broken Links" – Missing Shortcuts. My first logical guess is that maybe, just a simple hard drive re-attach will be enough in order to solve the problem. Detaching and Attaching the external Seagate hard drive made any change, whether opening the hard drive content with Windows File Explorer, most directories were just showing as Missing Shortcuts, like you can see from below screenshot:

windows XP problem with missing windows directory shortcuts screenshot external hard drisk error

I was a bit sleepy and in a hurry, so at first glimpse I didn't well read the Pop-upped Windows exact error, after carefully reading, I've realized the 689342.exe and the rest of ID.EXE that were trying to open, whether clicked on the "questionable", missing shortcuts is for sure some kind of most likely Polymorphous Spyware / Virus or a combination of both.

The person owning the computer, was quite in shock as most of his data was located on the external HD drive. My assumption of course was that the problem is not so severe as it looks, as I've fixed plenty of Windows-es with mixed up registry, which were mixing how Windows understands windows extensions.
My hope was that the problem will be solved by simply Checking the Windows Registry with – Little Registry Cleaner tool and fixing the irregularitieswith current registry, thus I did a quick scan with it fixed a bunch of registry problems, did the usual Windows restart, but this helped not. Thus I, therefore started a Malware Bytes Anti-Malware Spyware "Swiss Army Knife" prog 🙂. Paralelly with scanning I decided to check if physically files are present on Hard Disk, by dir listing the files in Windows command prompt – cmd.exe , there all seemed okay files and directories were present, I can CD into each of the directories incorrectly showing in Win File Explorer as missing shortcut and all inside dirs was just fine.

Dir listing if files are physically present Windows XP Screenshot

 

I checked for "autorun.inf", as it is so common nowadays that external Hard Drives and USB Sticks are infected with Autorun Virus variations and my guess happened to be right, there was F:\autorun.inf. As it is with the Autorun Virus-es the file was set the hidden and read-only atrribs. I checked it is there with:

> dir /a autorun.inf
...

Then I deleted autorun.inf, by reverting the "hidden and read-only attribs:

> attrib -s -h -r autorun.inf
> del autorun.inf

Though, I hoped this would solve the problem, checking f:\ Directories in File Explorer, continued to be showing Folders linked to the unexisting 689342.exe. Then I read some posts online, discussing the weird "Missing Shortcuts" issue and after a while thx God I finally got the fix, which is as simple as:

> attrib -r -s -h /s /d f:\*.*

This command, took about 20 minutes or so, as there are plenty of data on the hard drive. Also I suppose in some rare occasions the removal of read only, system and hidden windows attributes, might create issues of certain programs installed, however in this specific PC case all was okay and it doesn't really mattered as the really important files to rescue were mostly in .DOC's DJVu, PDF and plain text format along with some movies

 attrib cmd attributes command to fix missing shortcuts on windows XP picture shot

As you can see on below screenshot, I had the Malware Bytes running in parallel along with a Working copy of Avira Free Antivirus, while the above command was running Avira immediately detected a bunch of Virus files, which were offered to be Removed or Quarantined.

After removing, all of the badware and testing in Explorer, all folders in F:\ were showing as normal.
However, though all looked fine, after the completion of Malware Bytes scan and the removal of catched Malware, just to be sure something has not left as viruses I run oneanother Avira AV scan of all Computer Hard drives and did a Restart. This is it enjoy 😉

How and Why Walt Disney Is Trying To Corrupt You and Your Children

Thursday, May 24th, 2012

I've seen a number of videos exposing, a lot of symbolism, occultism and evil contained in Walt Disney's most famous videos.

I've been amazed that a first glimpse innocent looking cartoon can contain so much magical stuff, occult and hidden satanic symbolism.
Its been amazing that we still, are continuously flooding the youth with such openly anti-christian contained cartoons.

I guess even a lot of Christian devoted couples are playing this evil message movies.
On the first look it is not immediately evident what is happening in the movies, a kid could never understand how much bad stuff is contained inside. However a grown parents can easily see if they observe the movies closely. If you don't believe me check the few videos below and also just play some of your favourite kids cartoon and do a critical analysis of what is inside. There is no doubt there is everything inside, everything instead of our Saviour Jesus Christ.
We have become terribly crazy, since we learn the kids to look for anti-Christian lives, even from the very early stages of their childhood.

The result from such movies in the growing up youth is clear; they are attracted to movies with murder violence, sex related plots, stealing lies, ungodly music, love for evil and not a search for good, hatred, betrayal and all the evils, our grandfathers were teaching us to avoid …

How and Why Walt Disney Is Trying To Corrupt You and Your Children

Was Disney Satanic – Part 1

Was Disney Satanic – Part 2

Disney is pure evil

Journalism – How Disney Movies Corrupt Young Minds

There are plenty of psychological books explaining the badness over a child mind of such movies, yet parents are not careful to protect their children but rather encourage them to watch disney's production thinking they help the kid to develop their brain …
If you're a Christian and you know this things exist and they're preached, please be careful and try to select carefully what kind of movies you play to your kids.

If you're a grow up Christian and you've been raised with this movies, don't be in wonder why you have a very severe desire for sex, money, power and occult. The desire for all this ungodly things was 'installed' in you since the time of your youth simply by being bombarded with Disney's, Hanna Barbera and the rest of the 'all times cartoon' American popular cinema and cartoons.

How to solve “Incorrect key file for table ‘/tmp/#sql_9315.MYI’; try to repair it” mysql start up error

Saturday, April 28th, 2012

When a server hard disk scape gets filled its common that Apache returns empty (no content) pages…
This just happened in one server I administer. To restore the normal server operation I freed some space by deleting old obsolete backups.
Actually the whole reasons for this mess was an enormous backup files, which on the last monthly backup overfilled the disk empty space.

Though, I freed about 400GB of space on the the root filesystem and on a first glimpse the system had plenty of free hard drive space, still restarting the MySQL server refused to start up properly and spit error:

Incorrect key file for table '/tmp/#sql_9315.MYI'; try to repair it" mysql start up error

Besides that there have been corrupted (crashed) tables, which reported next to above error.
Checking in /tmp/#sql_9315.MYI, I couldn't see any MYI – (MyISAM) format file. A quick google look up revealed that this error is caused by not enough disk space. This was puzzling as I can see both /var and / partitions had plenty of space so this shouldn't be a problem. Also manally creating the file /tmp/#sql_9315.MYI with:

server:~# touch /tmp/#sql_9315.MYI

Didn't help it, though the file created fine. Anyways a bit of a closer examination I've noticed a /tmp filesystem mounted besides with the other file system mounts ????
You can guess my great amazement to find this 1 Megabyte only /tmp filesystem hanging on the server mounted on the server.

I didn't mounted this 1 Megabyte filesystem, so it was either an intruder or some kind of "weird" bug…
I digged in Googling to see, if I can find more on the error and found actually the whole mess with this 1 mb mounted /tmp partition is caused by, just recently introduced Debian init script /etc/init.d/mountoverflowtmp.
It seems this script was introduced in Debian newer releases. mountoverflowtmp is some kind of emergency script, which is triggered in case if the root filesystem/ space gets filled.
The script has only two options:

# /etc/init.d/mountoverflowtmp
Usage: mountoverflowtmp [start|stop]

Once started what it does it remounts the /tmp to be 1 megabyte in size and stops its execution like it never run. Well maybe, the developers had something in mind with introducing this script I will not argue. What I should complain though is the script design is completely broken. Once the script gets "activated" and does its job. This 1MB mount stays like this, even if hard disk space is freed on the root partition – / ….

Hence to cope with this unhandy situation, once I had freed disk space on the root partition for some reason mountoverflowtmp stop option was not working,
So I had to initiate "hard" unmount:

server:~# mount -l /tmp

Also as I had a bunch of crashed tables and to fix them, also issued on each of the broken tables reported on /etc/init.d/mysql start start-up.

server:~# mysql -u root -p
mysql> use Database_Name;
mysql> repair table Table_Name extended;
....

Then to finally solve the stupid Incorrect key file for table '/tmp/#sql_XXYYZZ33444.MYI'; try to repair it error, I had to restart once again the SQL server:

Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
Checking for corrupt, not cleanly closed and upgrade needing tables..
root@server:/etc/init.d#

Tadadadadam!, SQL now loads and works back as before!

How to solve “[crit] [client xxx.xxx.xxx.xxx] (13)Permission denied: /var/lib/ejabberd/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://jabber.mydomain.com/” – Error Cause and Solution

Thursday, January 5th, 2012

While configuring JWchat domain, I've come across around an error:

pcfg_openfile: unable to check htaccess file, ensure it is readable

The exact error I got in /var/log/apache2/error.log looked like so:

[crit] [client xxx.xxx.xxx.xxx] (13)Permission denied: /var/lib/ejabberd/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: http://jabber.mydomain.com/

The error message suggested /var/lib/ejabberd/.htaccess – is missing or not readable, however after checking i've seen .htaccess existed as well as was readable:

debian:~# ls -al /var/lib/ejabberd/.htaccess
-rw-r--r-- 1 www-data www-data 114 2012-01-05 07:44 /var/lib/ejabberd/.htaccess

At first glimpse it seems like the message is misleading and not true, however when I switched to www-data user (the user with which Apache runs on Debian), I've figured out the error meaning of unreadability is exactly correct:

www-data@debian:$ ls -al /var/lib/ejabberd/.htaccess
ls: cannot access /var/lib/ejabberd/.htaccess: Permission denied

This permission denied was quite strange, especially when considering the .htaccess is readable for all users:

debian:~# ls -al /var/lib/ejabberd/.htaccess
-rw-r--r-- 1 www-data www-data 114 2012-01-05 07:44 /var/lib/ejabberd/.htaccess

After a thorough look on what might go wrong, thanksfully I've figured it out. The all issues were caused by wrong permissions of /var/lib/ejabberd/.htaccess .You can see below the executable flag for all users (including apache's www-data) is missing :

debian:/var/lib# ls -ld /var/lib/ejabberd/drw-r--r-- 3 ejabberd ejabberd 4096 2012-01-05 07:45 /var/lib/ejabberd/

Solving the error, hence is as easy as adding +x flag to /var/lib/ejabberd :

debian:/var/lib# chmod +x /var/lib/ejabberd

Another way to fix the error is to chmod to 755 to the directory which holds .htaccess:

From now onwards pcfg_openfile: unable to check htaccess file, ensure it is readable err is no more 😉